Upgrade gone wrong

Off topic, tall tales, general chit-chat.
Post Reply
Manitou
Site Admin
Posts: 734
Joined: January 12th, 2014, 7:18 pm

Upgrade gone wrong

Post by Manitou »

I was attempting an upgarde of the phpbb code from 3.3.1 to 3.3.2 because I felt 2021 had started off too smoothly (sarcasm). It didn't work. I was able to restore from backup (good call all you guys that requesred and even paid for the backups). I didn't have to restore the database (just the core html type files). So, I think all posts are still here.. there's a chance we lost stuff from the past 24 hours though. There isn't anything I can do about it, but let me know of there is a recent post "gone" now.
chin_k
**Forum Contributor**
Posts: 1793
Joined: June 26th, 2017, 9:38 pm
Location: Southern CA

Re: Upgrade gone wrong

Post by chin_k »

It was down last night, but I did not notice anything missing, so I put my pitchfork away. :)
2000 Concourse dinette, on 2000 6.8L Ford E350 Triton V-10 Chassis (built in 1999)
chin_k
**Forum Contributor**
Posts: 1793
Joined: June 26th, 2017, 9:38 pm
Location: Southern CA

Re: Upgrade gone wrong

Post by chin_k »

Oh, someone reported missing attachment on the Electrical forum.
2000 Concourse dinette, on 2000 6.8L Ford E350 Triton V-10 Chassis (built in 1999)
Manitou
Site Admin
Posts: 734
Joined: January 12th, 2014, 7:18 pm

Re: Upgrade gone wrong

Post by Manitou »

ah, that makes sense about missing attachment. those files aren't put in the database. The database has the text of posts, but attachments upload as files. Not much I can do about it. attachments from January 7th will need to be reuploaded. sorry.
User avatar
Astrodokk
Posts: 407
Joined: July 30th, 2014, 7:06 am
Location: Seattle, WA

Re: Upgrade gone wrong

Post by Astrodokk »

I have found that I cannot upload JFIF pic files, but I found a work around by opening the pics with paint and re-saving as a jpeg file.
Not sure why most of my pics are being saved now by WIN10 as JFIF! It occurred after an update.
2000 Ford E350 415CI/6.8L V-10 Triton Chinook Concourse XL Club Lounge
Manitou
Site Admin
Posts: 734
Joined: January 12th, 2014, 7:18 pm

Re: Upgrade gone wrong

Post by Manitou »

I just added .jfif as an allowed file extension. Should work now. I've never heard of that file type, but a quick google says it should be legit.
Post Reply